767股票学习网 > 股票学校 > 大智慧公式 > 正文

PZGD捕捉拐点

{PZGD捕捉拐点}
{BLGD波浪拐点}
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
波动:MA(CLOSE,10000);
STICKLINE((MA15 > REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,color0000FF;
STICKLINE((MA15 < REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,colorFF0000;
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'★向上'),Color00FFFF;
DRAWTEXT(CROSS(MA15,FF),(HIGH * 1.02),'●向下'),COLORBLUE;
DRAWTEXT(CROSS(85,RSI),(HIGH * 1.02),'●回调'),COLORGREEN;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=cross(买线,卖线);
SEL:=cross(卖线,买线);
stickline(买线>=卖线,low,high,1,0),colorred;
stickline(买线>=卖线,close,open,4.5,0),color0000aa;
stickline(买线>=卖线,close,open,4,0),color0000cc;
stickline(买线>=卖线,close,open,3,0),color0000cc;
stickline(买线>=卖线,close,open,2,0),color0000ee;
stickline(买线<卖线,close,open,4.5,0),coloraaaa00;
stickline(买线<卖线,close,open,4,0),colorbbbb00;
stickline(买线<卖线,close,open,3,0),colorcccc00;
stickline(买线<卖线,close,open,2,0),coloreeee00;
stickline(买线<卖线,low,high,1,0),colorffff00;
stickline(cross(买线,卖线) or cross(卖线,买线),open,close,3,0),color00ffff;
趋势线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),linethick1,ColorFFffFF;
界: MA(CLOSE,27),linethick1,COLORff00ff;

GET:ZIG(3,5),COLORYELLOW,linethick2;
PL5:=ZIG(3,5);
EN1:=pl5>REF(pl5,1) AND REF(pl5,1)<=REF(pl5,2) AND REF(pl5,2)<=REF(pl5,3);
EX1:=pl5<REF(pl5,1) AND REF(pl5,1)>=REF(pl5,2) AND REF(pl5,2)>=REF(pl5,3);
PL10:=ZIG(3,10);
EN2:=pl10>REF(pl10,1) AND REF(pl10,1)<=REF(pl10,2) AND REF(pl10,2)<=REF(pl10,3);
EX2:=pl10<REF(pl10,1) AND REF(pl10,1)>=REF(pl10,2) AND REF(pl10,2)>=REF(pl10,3);
PL20:=ZIG(3,20);
EN3:=pl20>REF(pl20,1) AND REF(pl20,1)<=REF(pl20,2) AND REF(pl20,2)<=REF(pl20,3);
EX3:=pl20<REF(pl20,1) AND REF(pl20,1)>=REF(pl20,2) AND REF(pl20,2)>=REF(pl20,3);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'㈠'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'㈡'),COLORFFFF00;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'㈢'),COLORFFFF00;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'⑸'),COLOR0000FF;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.9,'Ⅰ'),colorred;
DRAWTEXT(EX2 AND DTJD10=2,H*0.9,'Ⅱ'),colorred;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.9,'Ⅲ'),colorred;

 下载地址:PZGD捕捉拐点

 
上一篇文章:
下一篇文章:

 





767股票学习网  www.net767.com  本站微博