767股票学习网 > 股票学校 > 飞狐公式 > 正文

飞狐实战指标5X版

DRAWGBK(C=C,COLORRGB(100,0,0),COLORRGB(160,80,160),1);;
A1:=(EMA(((O+H+L+C)/4),3)+EMA(((O+H+L+C)/4),6)+EMA(((O+H+L+C)/4),9))/3;
A2:=(EMA(((O+H+L+C)/4),5)+EMA(((O+H+L+C)/4),10)+EMA(((O+H+L+C)/4),20))/3;
A3:=(EMA(((O+H+L+C)/4),7)+EMA(((O+H+L+C)/4),14)+EMA(((O+H+L+C)/4),28))/3;
A4:=(EMA(((O+H+L+C)/4),9)+EMA(((O+H+L+C)/4),18)+EMA(((O+H+L+C)/4),36))/3;
A5:=(EMA(((O+H+L+C)/4),11)+EMA(((O+H+L+C)/4),22)+EMA(((O+H+L+C)/4),44))/3;
A6:=(EMA(((O+H+L+C)/4),13)+EMA(((O+H+L+C)/4),26)+EMA(((O+H+L+C)/4),52))/3;
A:(EMA(((O+H+L+C)/4),21)+EMA(((O+H+L+C)/4),34)+EMA(((O+H+L+C)/4),55))/3;
PARTLINE(A1>REF(A1,1),a1),coloryellow;
PARTLINE(A1<REF(A1,1),a1),colorblue;
PARTLINE(A2>REF(A2,1),a2),coloryellow;
PARTLINE(A2<REF(A2,1),a2),colorblue;
PARTLINE(A3>REF(A3,1),a3),coloryellow;
PARTLINE(A3<REF(A3,1),a3),colorblue;
PARTLINE(A4>REF(A4,1),a4),coloryellow;
PARTLINE(A4<REF(A4,1),a4),colorblue;
PARTLINE(A5>REF(A5,1),a5),coloryellow;
PARTLINE(A5<REF(A5,1),a5),colorblue;
PARTLINE(A6>REF(A6,1),a6),coloryellow;
PARTLINE(A6<REF(A6,1),a6),colorblue;
PARTLINE(A>REF(A,1),a),linethick3,colorred;
PARTLINE(A<REF(A,1),a),linethick3,colorgreen;

 

DYNAINFO(3);;
kx:=SYSPARAM(3)-SYSPARAM(2)+1;
kh:=hhv(high,kx);
kl:=llv(low,kx);
kmx:=kh[datacount];
kmn:=kl[datacount];
kbl:=(kmx+kmn)/2;
kgdc:=kmx-kmn;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
KA:=hhv(K,kx);
DA:=hhv(D,kx);
JA:=hhv(J,kx);
KB:=llv(K,kx);
DB:=llv(D,kx);
JB:=llv(J,kx);
mxak:=max(KA[datacount],max(DA[datacount],JA[datacount]));
mnak:=min(KB[datacount],min(DB[datacount],JB[datacount]));
kdbl:=(mxak+mnak)/2;
kdgdc:=mxak-mnak;

KC:(K-kdbl)*(kgdc/kdgdc)+kbl,COLOR801dae;
DC:(D-kdbl)*(kgdc/kdgdc)+kbl,COLOR9ed048;
JC:(J-kdbl)*(kgdc/kdgdc)+kbl,COLOR4c221b;


CLOSE,LINETHICK2,COLORblack;
HS:=VOL/SUM(VOL,BARSCOUNT(C));
FBMAX:dma(c,hs),LINEDASHDOT,LINETHICK2,COLORMAGENTA;

A:=REF(HHV(HIGH,240),1);
AA:=A[DATACOUNT];
B:=REF(LLV(LOW,240),1);
BB:=B[DATACOUNT];
ZJ1:=(((HIGH + LOW) + (2 * CLOSE)) / 4);
ZJ2:=(((ZJ1 - EMA(ZJ1,21)) / STD(ZJ1,21)) * 100);
ZJ3:=EMA(ZJ2,5);
ZJ4:=EMA(ZJ3,2);
ZJ5:=EMA(ZJ4,2);
ZJ6:=(((3 * ZJ4) - (2 * ZJ5)) / 2);
IF((ZJ6 > 90),(AA * 0.995),AA),LINETHICK2,colorAAEE33;
IF((ZJ6 < (0 - 95)),(BB * 1.005),BB),LINETHICK2,colorDD66AA;


{飞狐用下面这段显示阻力支撑}

DRAWTEXTEX(CLOSE,1,10,5,STKLABEL),LINETHICK4,colorFFFF00;
DRAWTEXTEX(CLOSE,1,140,5,STKNAME),LINETHICK4,colorFFFF;
DRAWTEXTEX(CLOSE,1,140,5,STKNAME),LINETHICK4,colorFFFF;

DRAWTEXT(OPENMINUTES(TIME)=5,c,'9.35');
DRAWTEXT(OPENMINUTES(TIME)=10,c,'9.40');
DRAWTEXT(OPENMINUTES(TIME)=15,c,'9.45');
STICKLINE(OPENMINUTES(TIME)=5,c*1.01,c*0.99,1,1);
STICKLINE(OPENMINUTES(TIME)=10,c*1.01,c*0.99,1,1);
STICKLINE(OPENMINUTES(TIME)=15,c*1.01,c*0.99,1,1);

 

下载地址: 飞狐实战指标5X版

 
上一篇文章:
下一篇文章:

 





767股票学习网  www.net767.com  本站微博