767股票学习网 > 股票学校 > 飞狐公式 > 正文

中线断股

中期主图,公式主要监控股价在空头市场的承压情况和确认突破,并且对多头和空头市场进行明显区分。
郑重建议新手在蓝色区域离场。
源码主要包括承压,轨迹,趋向三部分内容,旨在通过指标纵观全局,而进行合理的资金配置。
MA4:MA(CLOSE,250),LINETHICK2;
FILLRGN(C>1,MA4,MA4-(MA4-LLV(L,255))*0.25),COLORFF6633;
FILLRGN(C>1,MA4-(MA4-LLV(L,255))*0.25,MA4-(MA4-LLV(L,255))*0.5),COLORFF3333;
FILLRGN(C>1,MA4-(MA4-LLV(L,255))*0.5,MA4-(MA4-LLV(L,255))*0.75),COLORFF0033;
FILLRGN(C>1,MA4-(MA4-LLV(L,255))*0.75,MA4-(MA4-LLV(L,255))),COLORCC0033;
FILLRGN(C>1,LLV(L,255),LLV(L,255)*0.9),COLOR990033;
a0:=BARSCOUNT(c);a3:=SYSPARAM(3);a2:=SYSPARAM(2);
a4:=SYSPARAM(4);a5:=SYSPARAM(5);
nn0:=a3-a2;nn:=a0-a2;hh1:=(a4-a5)/8;
hh2:=hh1/4;
ll1:=llv(l,nn0);ll2:=ll1[a3];
y0:=a0>=a2;vv0:=if(y0=1 and SYSPARAM(1)>=a0,v,0);
c1:=if(BETWEEN(c,a4-0*hh1,a4-1*hh1),vv0,0);
c2:=if(BETWEEN(c,a4-1*hh1,a4-2*hh1),vv0,0);
c3:=if(BETWEEN(c,a4-2*hh1,a4-3*hh1),vv0,0);
c4:=if(BETWEEN(c,a4-3*hh1,a4-4*hh1),vv0,0);
c5:=if(BETWEEN(c,a4-4*hh1,a4-5*hh1),vv0,0);
c6:=if(BETWEEN(c,a4-5*hh1,a4-6*hh1),vv0,0);
c7:=if(BETWEEN(c,a4-6*hh1,a4-7*hh1),vv0,0);
c8:=if(BETWEEN(c,a4-7*hh1,a4-8*hh1),vv0,0);
c9:=if(BETWEEN(c,a4-8*hh1,a4-9*hh1),vv0,0);
c10:=if(BETWEEN(c,a4-9*hh1,a4-10*hh1),vv0,0);
v1:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c1,nn0),0),2)),LINETHICK;
v2:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c2,nn0),0),2));
v3:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c3,nn0),0),2));
v4:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c4,nn0),0),2));
v5:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c5,nn0),0),2));
v6:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c6,nn0),0),2));
v7:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c7,nn0),0),2));
v8:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c8,nn0),0),2));
v9:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c9,nn0),0),2));
v10:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c10,nn0),0),2));
av0:=max(v1,max(v2,max(v3,max(v4,max(v5,max(v6,max(v7,max(v8,max(v9,v10)))))))));
x1:=v1/av0>=nn/nn0 and nn>=0;
x3:=v3/av0>=nn/nn0 and nn>=0;
x5:=v5/av0>=nn/nn0 and nn>=0;
x7:=v7/av0>=nn/nn0 and nn>=0;
FILLRGN(v1/av0>=nn/nn0 and nn>=0,a4-0*hh1,a4-1*hh1+hh1*0.5),COLOR00008F;
FILLRGN(v2/av0>=nn/nn0 and nn>=0,a4-1*hh1,a4-2*hh1+hh1*0.5),COLORRED;
FILLRGN(v3/av0>=nn/nn0 and nn>=0,a4-2*hh1,a4-3*hh1+hh1*0.5),COLOR00AADD;
FILLRGN(v4/av0>=nn/nn0 and nn>=0,a4-3*hh1,a4-4*hh1+hh1*0.5),COLOR8C8EB5;
FILLRGN(v5/av0>=nn/nn0 and nn>=0,a4-4*hh1,a4-5*hh1+hh1*0.5),COLOR387C7C;
FILLRGN(v6/av0>=nn/nn0 and nn>=0,a4-5*hh1,a4-6*hh1+hh1*0.5),COLOR555555;
FILLRGN(v7/av0>=nn/nn0 and nn>=0,a4-6*hh1,a4-7*hh1+hh1*0.5),COLORFF55FF;
FILLRGN(v8/av0>=nn/nn0 and nn>=0,a4-7*hh1,a4-8*hh1+hh1*0.5),COLORFFFF00;
启动线:=(SUM(EMA((C+L)/2,2)/2.98,3)),COLORRED;
平衡线:=LLV(SUM( EMA((C+L)/2,2)/2.98,3),4),COLORMAGENTA;
平台线:=LLV(SUM( EMA((C+L)/2,2)/2.98,3),8),COLORFFFFFF;
强弱线:=EMA(启动线,21),COLORYELLOW;
STICKLINE(平台线<启动线,启动线,平台线,0.1,0),COLORFF972F;
STICKLINE(平衡线<启动线,启动线,平衡线,0.1,0),COLORRED;
Var1:=2*MA(LLV((C+L)/2,8)*1.1,13)-EMA((C+L)/2,3)-((C+L)/2)*0.1;
Var2:=if((EMA((C+L)/2,3)-Var1)*5>0,POW((EMA((C+L)/2,3)-Var1)*5,2)/10,-1*POW((EMA((C+L)/2,3)-Var1)*5,2)/10);
Var3:=IF(Var2>0,Var2-0,-1);
Var4:=ema(h,3);
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFFFF00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorCCCC33;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2.4,0),colorFFFF00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.1,0),colorFFFFFF;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,9,0),color33CC;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,6,0),colorCC;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,2.4,0),colorFF;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,1.1,0),colorFF00FF;
STICKLINE((CLOSE > OPEN),OPEN,LOW,0.5,0),colorCC;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0.5,0),colorCC;
STICKLINE((OPEN >= CLOSE),CLOSE,LOW,0.5,0),colorFFFF00;
STICKLINE((OPEN >= CLOSE),OPEN,HIGH,0.5,0),colorFFFF00;
DRAWTEXT(CROSS(Var3,0)AND (C+L)/2>MA((C+L)/2,8) ,强弱线*1.01,'注控'),LINETHICK2,ALIGN0,COLORFFFFFF;
注意风险: STICKLINE((SMA(MAX((C+L)/2-REF((C+L)/2,2),0),7,1)/SMA(ABS((C+L)/2-REF((C+L)/2,2)),7,1)*100)>80,Var4+0.1,Var4+0.2,6,0),COLORFF972F;
价位:=SMA((C-LLV(L,26))/(HHV(H,26)-LLV(L,26))*100,8,1);        
控制风险:STICKLINE((3*价位-2*(SMA(价位,3,1)))>75.8,Var4+0.2,Var4+0.3,6,1),COLORYELLOW;
风:=((H+C)/2+L+(C+L)/2)/3;
险:=EMA((风-EMA(LLV(风,47),2))/(EMA(HHV(风,21),2)-EMA(LLV(风,47),2)),2)*90;
风险:STICKLINE(险>86.8,Var4,Var4+0.1,6,1),COLORFFFFFF;
多空:=OPEN;
FILLRGN(C>=LLV(L,0),MA4*1.15,MA4),COLORGRAY;
FILLRGN(C>=LLV(L,0),MA4*1.15,MA4*1.1),COLOR888888;
MA1:MA(CLOSE,3),LINETHICK2;
MA2:MA(CLOSE,8),LINETHICK2;
MA3:MA(CLOSE,55),CIRCLEDOT,COLORRED;
MA180:MA(CLOSE,180),LINETHICK2;
MA377:MA(CLOSE,377),LINETHICK2;
WZ1:=SYSPARAM(3)-BARSCOUNT(c);
WZ2:=CEILING((SYSPARAM(3)-SYSPARAM(2))*0.85);
WZ3:=CEILING((SYSPARAM(3)-SYSPARAM(2))*0.95);
DRAWTEXT(WZ1=WZ2,MA4*1.15,'生存之道=资本为王,以小胜,集大胜!'),COLORYELLOW,LINETHICK2;
DRAWTEXT(WZ1=WZ3,MA4*0.9,'海洋'),COLORMAGENTA;
DRAWTEXT(WZ1=WZ3,MA4*1.1,'陆地'),COLORGREEN;
DRAWTEXT(WZ1=WZ3,MA4*1.2,'天空'),COLORWHITE;
DRAWTEXT(FILTER((C>MA4*1.01) AND ALL(REF(C,1)<MA4*1.02,55),89),C*1.15,'冲\n出\n苦\n海'),COLORWHITE;
DRAWTEXT(FILTER((C>MA4*1.15) AND ALL(ref(c,1)<MA4*1.16,55),89),C*1.15,'破\n土\n而\n出'),COLORWHITE;

 

下载地址: 中线断股

  上一篇文章:
下一篇文章: 没有了

 





767股票学习网  www.net767.com  本站微博