767股票学习网 > 股票学校 > 通达信公式 > 正文

变色趋势,上涨下跌一目了然

清晰的趋势指标,变色买卖。

VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;
VAR4:=EMA(VAR3,5);
VAR5:=3*VAR3-2*VAR4;
AAA:=CROSS(VAR5,VAR3) AND VAR3<2.1 AND C>O;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
多:VAR9,COLORBLUE,POINTDOT;
空:EMA(0.382*REF(VAR9,2)+0.618*VAR9,12),COLORYELLOW;
STICKLINE(VAR9>VARA,VAR9,VARA,6,0),COLORBLUE;
STICKLINE(VAR9<=VARA,VAR9,VARA,6,0),COLORYELLOW;
Y:=(H+O+L+3*C)/6;
X:=EMA(100-(100/(1+SUM(IF(Y>REF(Y,1),Y*VOL,0),14)/SUM
(IF(Y<REF(Y,1),Y*VOL,0),14))),5),COLORBLUE;
A1:=30,COLORWHITE;
A2:=50,COLORWHITE;
A3:=60,COLORFF0080;
A4:=70,POINTDOT;
A5:=80,COLORRED;

MA5:=MA(C,5);
MA6:=MA(C,6);   
MA10:=MA(C,10);
MA20:=MA(C,20);
A2M:=REF(MA20,1);
J1:=(MA20-A2M)/A2M*100;
MJ1:=MA(J1,3);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;   
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);   
MAX1:=MAX(MA20,MA30);   
MAX2:=MAX(MAX1,MA60);   
MIN1:=MIN(MA20,MA30);   
MIN2:=MIN(MIN1,MA60);   
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}   
VAR2N:=IF(K1<=8,1,0);
短线暴张:DRAWTEXT(FILTER( (VAR1 OR VAR2N) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60   AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
AND MA(V,60)>REF(MA(V,60),1),5),68,'暴张'),COLORYELLOW;
DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND  J1>MJ1 AND MA60>REF(MA60,1) AND  COUNT(J1<1,3)>=1 ,58,'买入'),COLORWHITE;
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);   
XL3:=CROSS(XL2,(0 - 20));   
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),42,'买点'),COLORBLUE;
DRAWTEXT((XL3 > 0),50,'底部'),COLORYELLOW;
X6:=REF(CLOSE,1);   
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);   
X8:=CROSS(79,X7);   
X9:=FILTER(X8,4);   
DRAWTEXT(X9, 56,'出货'),COLOR9000F5;
VARQ1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VARQ2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VARQ3:=SMA(VARQ2,2,1);
天:=100+(-ABS(VARQ1)),COLORRED;
下:=SMA(VARQ3,2,1);
选股2:=IF(CROSS(下,20),1,0);
DRAWICON((CROSS(下,20) ),30,1);
V1:=EMA(CLOSE,60)-EMA(CLOSE,300);
V2:=EMA(V1,300);
V3:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
操盘线:=SMA(V3,2,1),LINETHICK3;
V5:=SMA(操盘线,2,1);
抄底:=IF(操盘线>REF(操盘线,1) AND REF(操盘线,1)<REF(操盘线,2) AND 操盘线<23 ,18,0),COLORYELLOW,LINETHICK3;
追买:=IF(操盘线>REF(操盘线,1)  AND CROSS(操盘线,V5) AND V5<50,8,0),COLORRED;

下载地址:变色趋势

  上一篇文章:
下一篇文章:

 





767股票学习网  www.net767.com  本站微博